General

This is for general discussions. Also FAQ can be found here.

Moderator: speedake95

  • Forum
    Topics
    Posts
    Last post
New Topic
  • Topics
    Replies
    Views
    Last post
  • Electricity problem
    by 3djohny »
    13 Replies
    1967 Views
    Last post by fesch
  • first layer
    by Raleonh »
    4 Replies
    658 Views
    Last post by fesch
  • TPU printing
    by rickconterra »
    1 Replies
    707 Views
    Last post by DDME-MarcUser avatar
  • Anyone printing with Ninjaflex?
    by seaton »
    13 Replies
    2804 Views
    Last post by fesch
  • Make Magazine Shootout Objects
    by kerog »
    1 Replies
    458 Views
    Last post by satoer
  • Lines in layer uneven
    by Niho3D »
    3 Replies
    594 Views
    Last post by Niho3D
  • Shipping a Felix
    by Kentxu »
    1 Replies
    437 Views
    Last post by satoer
  • Z-Axis calibration problem
    by seaton »
    4 Replies
    697 Views
    Last post by seaton
  • Felix 3.0 Extruder clog
    by falconisimator »
    9 Replies
    1610 Views
    Last post by jjlink
  • This is why I chose the Felix,
    by satoer »
    2 Replies
    553 Views
    Last post by gfeliksdalUser avatar
  • forum search function does not work properly
    by neep »
    2 Replies
    482 Views
    Last post by satoer
  • PVA Glass in Extruder
    by WayneC »
    5 Replies
    675 Views
    Last post by WayneC
  • What happened with Make review?
    by kerog »
    3 Replies
    835 Views
    Last post by emdash
  • Felixprinter 1.5: Pictures, Problems, Solutions and upgrades
    by satoer »
    24 Replies
    12711 Views
    Last post by jjlink
  • Extruder does not heat up
    by F3DSB1 »
    0 Replies
    642 Views
    Last post by F3DSB1
  • Goodbye, Painter's Tape!
    by WayneC »
    0 Replies
    641 Views
    Last post by WayneC
  • Anyone tried buildtak?
    by killejano »
    0 Replies
    587 Views
    Last post by killejano
  • V1.5 to V3 Problems and Concerns
    by daveinhull »
    0 Replies
    569 Views
    Last post by daveinhull
  • X Axis shifting back and forth mid-print
    by ajkass »
    5 Replies
    1163 Views
    Last post by cbensch
  • Poor printing quality
    by Phipso »
    8 Replies
    1210 Views
    Last post by cbensch
  • Layers drift to +X axis with increasing Z height
    by johnandreid »
    2 Replies
    739 Views
    Last post by johnandreid
  • Unable to use print head 2
    by WayneC »
    5 Replies
    721 Views
    Last post by kerog
  • Gluing PLA
    by Formatize »
    6 Replies
    1147 Views
    Last post by WayneC
  • Good (Best) PLA filament
    by Raleonh »
    6 Replies
    1120 Views
    Last post by aaagul45
  • Acetone slurry not working
    by kerog »
    3 Replies
    754 Views
    Last post by NikolaiD
New Topic

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum