Major help needed - Multiple issues!!

This is for general discussions. Also FAQ can be found here.

Moderator: speedake95

Post Reply
stratogavster
Posts: 120
Joined: Tue Jul 17, 2012 9:04 pm
Location: United Kingdom

Re: Major help needed - Multiple issues!!

Post by stratogavster »

Thanks for all the support!

Well hoping for a replacement...really can't rewire this thing anymore...it's killing me!!...had it ages and haven't done much with it as it's been a total nightmare....starting with the x-axis! wish I had spotted that weeks ago! it could have nipped this in the bud....oh well...one day i'll have a working printer...fingers crossed...

stratogavster
Posts: 120
Joined: Tue Jul 17, 2012 9:04 pm
Location: United Kingdom

Post by stratogavster »

Update for all...

Swapped electronics to Reprapdiscount versions......all problems fixed!! I have a working printer!! :D

Obviously broken RAMPS and / or Arduino Clone :(...

...though after chatting to a software engineer I work with, he mentioned that my USB troubles are very likely not all down to the Dell, but how it actually interacts with the FTDI chip. Apparently the FTDI chip has to be programmed with a power consumption value which the host PC reads in expectation of the power required. If the figure programmed doesn't match what the USB can deliver then it's asking for trouble....his theory is that the Dells USB implementation was less than forgiving (whereas the macs is better), and the Dell was fooled into thinking the Arduino needs lots of current, hence intermittent issues regardless of USB sleep mode state.

This only covers part of the issue...in general I think the whole package was busted!

Moving on...I've added a Reprapdiscount LCD / SD controller to the mix....printing with no computer now pretty well, think there is room for improvement and can't really find much literature regarding the usage of the controller...will post elsewhere for help there.

Thanks again to all!

Post Reply

Return to “General”