printer rebooting after usb cable is connected

Post Reply
vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

printer rebooting after usb cable is connected

Post by vinteg »

hi there,

it's been 3 weeks since i had switched on my felix printer.
however, something is failing.
whenever i connect it to my PC it starts to reboot.
ten seconds on, 2 seconds off, 10 seconds on, 2 seconds off

if i disconnect the cable it keeps running.
now it's not the cables, i tried three of those.
it's also not a problem with the usb voltage port, every other usb device i connect to my pc works fine.
if i connect it the FT232R UART shows up on my pc as normal.
repetier host cannot connect to the printer even though my com ports are set right

i have no idea what is wrong or could cause the problem. since nothing has changed on my pc i'm frightfull my controller board is boarked...

any help would do!

vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

Post by vinteg »

small update, just tried in on an old win 7 laptop...no problem and printer stays online.

vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

Post by vinteg »

update 2...also tried using the drivers from the FTDI website itself. no solution.

also i forgot to mention that in repetier host i get 'acces to com port 12 denied'
so i'm guessing something is messing with my com ports

vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

Post by vinteg »

solved!

for every person getting this problem here is the sollution:

run regedit

go to HKEY_Local_machine

system

currentcontrolset

control

com name arbiter

if you there in the right pane there should be a value called ComDB

right click it

modify

and you will see a screen full of values

select all the numbers and pres 'DEL'

press ok

and reboot your pc

your COM database is now reset and everything will run again ;)

vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

Post by vinteg »

seems like after two emergency stops the same thing is happening.
i'm going to format my pc and see if it works then.

Dreide
Posts: 176
Joined: Sun Sep 29, 2013 12:32 am
Location: Lausanne, Switzerland

Post by Dreide »

I am wondering if your problem is caused by this: http://arstechnica.com/information-tech ... e-hackers/, as it is a bit strange that it started not working just from one day to the other and just with one PC, while it did work with some old laptop (which might not have been updated/spoiled by Windows Update???). You might want to try re-installing the old USB driver.
On the other hand, if it really was a driver problem caused by Windows Update, why does nobody else seem to have such problems?
Felix 2.0->3.0dual * Repetier (host+firmware) * KISSlicer Pro, Simplify3D * Cubify Design

vinteg
Posts: 6
Joined: Sun Nov 23, 2014 5:51 pm

Post by vinteg »

well i can still see the VID's and PID's. and those check out. so the chip has not been reprogrammed.
i did notice however that an update was applied recently. so i will try to remove it and see what happened. thx for the info BTW!

Post Reply