Inductance Auto Leveller

This is the place to show off your felix printer hacks and improvements.
Post Reply
seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

Inductance Auto Leveller

Post by seaton »

Has anyone done this?

Ive just ordered a sensor, but was wondering what needs to be done in terms of i/o, is it just replace the existing Z-Stop with the Sensor output?

Thanks
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

3dhuynh
Posts: 9
Joined: Tue Apr 08, 2014 4:01 am

Post by 3dhuynh »

Seaton,
I haven't try this yet, but watch this video hope it could help you.
let me know how it goes. I may order one and try it.

https://youtu.be/lgVmNuwMH68

..

seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

Post by seaton »

Thanks for that. Funnily enough I was watching that last night along with toms guide. Both informative. My sensors arrived yesterday so will look at having a play as soon as things quieten down at work
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

fanass
Posts: 22
Joined: Mon Oct 20, 2014 6:51 am

Post by fanass »

Seaton,

i've tried an (capacitive) Sensor for autobed levelling and got frustrated.
I mounted the sensor near to the hotends, removed the z-sensor wires and connected the capacitive-sensor to the z-sensor connector (via optocopler). The sensor itself works like a charm. The firmware detects, when the sensor
changes is state.
Then i enabled z_probe and autobed levelling in the firmware. z_probe itself and autobed levelling work perfectly (G29 and G32 command), but i ran into troubles with z-homing.
When i enable Z_MIN_ENDSTOP, z-homing works perfectly, but the nozzles fly abt. 3mm above the bed (the difference between trigger of the sensor and nozzle-height). I cannot move the bed nearer beause of the endstop.
When i disable Z_MIN_ENDSTOP sometimes the nozzles of my printer crash onto the bed due to missing Endstop.
As I read in another forum Z_MIN_ENDSTOP in comination with Z_PROBE and bed levelling does not work.
I would like mount the old optosensor of the z-axis as Z_MAX_ENDSTOP for z-max homing, but i don't know where to connect to the board. There are undocumented OPT1 ans OPT2 connectors.

Post Reply