XYZ not going into home position

Post Reply
pinobecker
Posts: 1
Joined: Thu Jul 26, 2012 10:36 pm

XYZ not going into home position

Post by pinobecker »

Upgraded from 1.0 to 2.0, installed Repetier Host 0.85, so far everything looks alright except all axis won't stop at the opto-sensors.
I can see the opto-sensor lights on the new Felix board going off when the fane enters, the LEDs on the opto-sensors however won't light up at all.
So they're passing the information but the axis won't stop.
Also when hitting the home button for the X axis the axis moves back about a cm and then advances for a little more then a cm, so pressing the x home button repeatedly will eventually land the extruder on the wrong site.
The Z axis won't get to the opto-sensor when pressing the Z home button, even if the light on the felix board on, it just doesn't move upwards.
The Y axis ignores the opto-sensor, resulting in that nasty noise, because the bed can't slide any further.
Pressing any of the Repetier Host advance buttons (+) however will move the respective axis as expected.

Any suggestions are very much appreciated!

dsarmiento
Posts: 6
Joined: Fri Jun 21, 2013 3:59 pm

Post by dsarmiento »

Hello, I think I have the same problem over here. I purchased a Felix 2.0 DIY kit, assembled well and when I go to Manual Tab on Repetier, the only axis that seems to recognize Home is Y Axis. The others (X and Z) justo go to positive direction when I press Home buttons. I placed some bright stickers on opto vanes and double check that Opto LEDs on circuit board go off when the vanes touches the sensors. Please any help??

bhavesh3e
Posts: 10
Joined: Sat May 25, 2013 1:25 pm
Location: India

Post by bhavesh3e »

Your Printer's opto sensors are not working need to change them.

I found same kind of bug for the Z axis of my 2.0 printer.

Check the below mentioned post for more Bug details:

http://www.felixprinters.com/forum/view ... 3161#p3161

dsnijders
Posts: 30
Joined: Fri Jul 26, 2013 4:13 pm

Post by dsnijders »

I had a similar issue with my Felix 2.0 printer:

- opto sensors did not with off of all three axes.
- printer would not go 'HOME'.

When I compared the wiring on the mother board, with the wiring on the sensor, i discovered a difference which fix it.

- wiring sequence mother board: Yellow (signal), Black (GND), Red (VCC) (see page 42, from left to right)
- wiring sequence opto sensor: Red (VCC), Yellow (Signal), Black (GND) (see page 40, showing Red/Black/Yellow from left to right).

See picture attached.

This fixed it for me:

- opto sensors all work now
- HOME works now for all axes.

Hope this helps at least some of you with similar issues.
Opto sensor wiring felix 2.0
Opto sensor wiring felix 2.0

kimmoli
Posts: 62
Joined: Fri Mar 08, 2013 1:15 pm
Location: Finland

Post by kimmoli »

There is two diferent versions of the opto-sensors, one with GND - SIGNAL - VCC wiring, and another with SIGNAL - GND - VCC.
I think this should be mentioned on instructions... There are printings on the opto board - follow those.

From version 1.5 manual.
Kuvakaappaus 2013-08-19.png
from version 2.0 manual.
Kuvakaappaus 2013-08-19 07.png
Kuvakaappaus 2013-08-19 07.png (74.26 KiB) Viewed 987 times
our 1.5 was shipped with those white ones, which differ from 1.5 manual pictures.

Post Reply