Tec4 (simplify3D) printer profiles

Post Reply
frankjoke
Posts: 150
Joined: Sat Dec 28, 2013 6:07 pm

Tec4 (simplify3D) printer profiles

Post by frankjoke »

I got my Tec4 Dual yesterday (was using a v3 since ~4 years).

Now after some testing I can say that some of the features are very nice: Bed leveling for example!

Nevertheless, there are some annoying things as

For the new Z-Home the printer heats up the (both)head(s) to 120°C
I had simplify3D and imported the Tec4-profile. Unluckily it seems to be built from Pro version!

Nyhow, my first prints were single (left) extruder and I found that:

* The Printer heats up first to the temperature of the (left) extruder. But when G28 (Home all) comes in it removes the required temperature and sets 120°C for all extruders, so also it waits for the second extruder not in use to heat up to 120. Meanwhile first cools down ...
Now, after both extruders are >=120 the Z is homed and the heads move to (too low) first position and wait until extruder and bed has temperature.

I had to change startup script to:
start heat up bed (to desired) and both extruders to 120
Then home all axes and go to a 'parking' position
Set right extruder to 0°C
Then heat up left extroder to desired °C without waiting
Wait until bed is also on final °C
Then wait fopr left extruder (T0) on filen °C (it will be there normally faster than the bed)
seset extruder .... and start pinting

User avatar
gfeliksdal
Site Admin
Posts: 405
Joined: Sat Feb 25, 2012 10:40 pm
Location: Netherlands
Contact:

Post by gfeliksdal »

Hi Frank,

Thanks for the feedback.

The 120 deg is used to ensure new users don't kill the top layer of the buildplate, if they are homing with a cold nozzle with a blob of plastic on it. If you really want to disable it you have to change it in the firmware. Just a single parameter.

The startup gcode in simplify is indeed not optimal yet, we have it on the todo-list, but takes some time.

frankjoke
Posts: 150
Joined: Sat Dec 28, 2013 6:07 pm

Post by frankjoke »

Ok, would be great to disable it because in 90% I print with one of the extruders only and do not want to heat up both. Octopi has also a Repetier-Firmware setting editor but I could not find the (right) setting there.

User avatar
gfeliksdal
Site Admin
Posts: 405
Joined: Sat Feb 25, 2012 10:40 pm
Location: Netherlands
Contact:

Post by gfeliksdal »

You can disable it by changing the configuration.h file from the firmware source.
2017-11-21_133750.png
2017-11-21_133750.png (10.17 KiB) Viewed 1622 times
Then upload it via arduino to the printer.

frankjoke
Posts: 150
Joined: Sat Dec 28, 2013 6:07 pm

Post by frankjoke »

Thanks a lot, did the update.

Beta
Posts: 19
Joined: Sat Mar 03, 2018 6:23 am

Post by Beta »

There's one thing I haven't liked about the startup script, other than the heat-up sequence:

When the purge/wipe of Extruder 1 (the left-side extruder) happens, it does its movement along the X-axis. Any blobs that happen to occur and come off inevitably end up stuck on Extruder 2. It would be better to purge Extruder 1 along the Y-axis at near maximum X, and Extruder 2 along the Y-axis near minimum X. That way there's zero chance of blobs sticking to either extruders.

Post Reply