How to print smooth curves ?

This is for general discussions. Also FAQ can be found here.

Moderator: speedake95

Post Reply
Hugues
Posts: 270
Joined: Thu Apr 04, 2013 5:36 pm

How to print smooth curves ?

Post by Hugues »

I need to print part of a spherical shell but the surface is not smooth, it shows kind of flat surfaces assembled together.

I see that when the printer extrudes an arc on the bed, it's not exactly an arc but it's more composed of straight lines at an angle of each other. YOu can actually hear the stepper motor changing pitch for each segment printed.

Is there a way to print perfectly smooth curves ? i mean by perfectly, something the eye cannot distinguish ? Surely the electronic on board and these stepper motors can do better than that ?

Or is the problem with my CAD software ? I use Inventor Fusion. I attach my stl file i'm trying to print properly. I cannot see any flat surfaces on screen really.

Surely there is a solution to this.
Attachments
hemi.stl
(285.03 KiB) Downloaded 51 times
Hugues
Regards from Switzerland

seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

Post by seaton »

I'm pretty well sure that its the way the CAD exports to STL, it's how the arcs are represented in STL as the STL is really just a collection of points in space, there is no concept of curves, other than how many points connected by straight lines are on the curve. I've not used Inventor Fusion so I don't know what you can set for STL export, however I'm using Geomagic Design (calibre) and when I export to STL I get an option of how it handles curve resolution i.e. how many lines to represent the curves.

Stephen...
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

dognotdog
Posts: 181
Joined: Tue Sep 04, 2012 9:22 pm

Post by dognotdog »

STLs are composed of flat triangles for the surface. Arc detection is experimental in some slicers, you could try that, but it mostly doesnt work.

Hugues
Posts: 270
Joined: Thu Apr 04, 2013 5:36 pm

Post by Hugues »

seaton wrote:I'm pretty well sure that its the way the CAD exports to STL, it's how the arcs are represented in STL as the STL is really just a collection of points in space, there is no concept of curves, other than how many points connected by straight lines are on the curve. I've not used Inventor Fusion so I don't know what you can set for STL export, however I'm using Geomagic Design (calibre) and when I export to STL I get an option of how it handles curve resolution i.e. how many lines to represent the curves.

Stephen...
it does make sense. I just tried to view my stl file in anotehr viewer and it does look like the printed model, with these flat surfaces.

I will check if there is a parameter in inventor fusion to impact this,

thanks for the lead,
Hugues
Regards from Switzerland

kimmoli
Posts: 62
Joined: Fri Mar 08, 2013 1:15 pm
Location: Finland

Post by kimmoli »

To get smooth arcs, the firmware (and others) should support native G2 and G3 circular interpolation G-codes. Otherwise arcs are still "flats".
And even when those are supported, it is the low-level axis control which may again make your arcs flat (have seen this in my own code).

I think best way is to find adjustment of the STL triangle generation when exporting from CAD to STL, if such exists.

Lioric
Posts: 116
Joined: Wed Aug 15, 2012 1:13 am

Post by Lioric »

In the screen displayed object, the normals are interpolated per vertex (when using gouraud shading) so it displays a continuous surface even when it is made out of non smooth surfaces (as in flat surfaces at different angles forming an arc). In other words is a trick to use less polygons and produce a smooth surface representation.

But that is not what the printer sees, as the slicer only knows about the location of vertices and faces and nothing else.

So you need to increase the resolution of the exported mesh, for it to contain more "control points" forming a smooth arc. In inventor at the stl export time you can open "options" and select "High" resolution.
Or you can open your stl file in another modeling app and tessellate to increase the resolution (I'm not really sure but I think netfabb has that option)

But then as noted above, the firmware has support for smooth arcs already included (Marlin, the firmware used in the Felix printer already supports this), so you might want to play with your slicer settings (or even better I can recommend you to try Kisslicer, for me it was as if I had another completely improved, better resolution and better accuracy printer after switching to this slicer, and not mentioning higher quality printed parts)

kimmoli
Posts: 62
Joined: Fri Mar 08, 2013 1:15 pm
Location: Finland

Post by kimmoli »

I'm using Varicad for designing parts, and after my own comment i found out that it has one STL export setting which affected this.

See following for my quick test; https://plus.google.com/110099222044661 ... VUpdCKJVgJ

I have also try that kisslicer, so far i have only used sfact

Hugues
Posts: 270
Joined: Thu Apr 04, 2013 5:36 pm

Post by Hugues »

Lioric wrote:... In inventor at the stl export time you can open "options" and select "High" resolution....
Which version of Inventor you have ?
I have the mac version of inventor fusion and there is no options button when exporting to stl, and i checked all menus, i did not see anything where we can specify the resolution of the stl file :cry:
Last edited by Hugues on Tue Aug 06, 2013 6:54 pm, edited 1 time in total.
Hugues
Regards from Switzerland

hoolito
Posts: 95
Joined: Wed Feb 27, 2013 7:15 pm

Post by hoolito »

I use NX from Siemens and my license does not include STL export. So I export to STEP and the open it in HeeksCAD (free) and resave as STL. This does have settings for STL resolution (chord lengh aka triangle generation). But I don't know if there's an OSX version.
Felix 2.0

Lioric
Posts: 116
Joined: Wed Aug 15, 2012 1:13 am

Post by Lioric »

Hugues wrote: Which version of Inventor you have ?
I have the mac version of inventor fusion and there is no options button when exporting to stl, and i checked all menus, i did not see anything where we can specified the resolution of the stl file :cry:
I'm on Windows (and Linux if possible)

I try to say away from anything MAC, but maybe on something similar as "Document settings" or so a resolution setting may be found.
I have also try that kisslicer, so far i have only used sfact
Kisslicer is on very different league, with SFACT I was constantly tweaking and changing parameters and the quality was not that good (visible seams, weak perimeters and so) but with Kisslicer the quality of the very first print was impressive (even before any fine tunning) and it slices in seconds (compared to several minutes on python based SFACT, and I'm on a 16GB Intel I7 beast) so i is very easy and fast to test different settings.

As noted above, Kisslicer is as if I have a new and improved printer

Post Reply