Lockups

Discussions about the electronics
Post Reply
Capella_Ben
Posts: 88
Joined: Thu Aug 08, 2013 10:01 am
Location: Queensland, Australia

Lockups

Post by Capella_Ben »

Hi,

On the last two prints, the printer simply stopped working and failed to respond to commands. I tried pausing the print and moving the head, also killing the job, but I got no response.

In repetier host, I hit the "emergency stop" button and the printer did respond to that. However afterwards, it was still locked up.

A cold reboot, brought it back, but it's a worrying development.

Has anyone else had this happen?
Ben
..
Felix 3.0 (upgraded from 2.0)

Makron
Posts: 110
Joined: Wed Mar 20, 2013 1:29 pm

Post by Makron »

I had to do a 14 hour print yesterday and i also had 1 two times , the first time i could restart is thanks to satoer's guide ,But the second time it failed with only 10 layers to go :( .

I dont know how it commes im testing now printing from the sd-card.

andrewsi
Posts: 130
Joined: Mon Dec 23, 2013 1:26 am

Post by andrewsi »

Repetier or Marlin firmware? Just FYI, the drops provided on the Felix website are somewhat old and it's not terribly difficult to build the latest from Github. I can provide some assistance with that if needed, on the off chance that what you ran into is a bug that has been fixed in later versions.

The symptoms you describe (cold boot fixes it, etc.) are pretty likely a firmware problem rather than a defective board. If you reprint the same gcode does it lock up in the same place?
__________________________________________
Andy Silverman, Technogeek in Seattle
Felix Tec4 Single-head

Capella_Ben
Posts: 88
Joined: Thu Aug 08, 2013 10:01 am
Location: Queensland, Australia

Post by Capella_Ben »

Makron wrote:I had to do a 14 hour print yesterday and i also had 1 two times , the first time i could restart is thanks to satoer's guide ,But the second time it failed with only 10 layers to go :( .

I dont know how it commes im testing now printing from the sd-card.
Hi Makron,

What guide are you referring to? Do you have the link handy?

Thanks
Ben
..
Felix 3.0 (upgraded from 2.0)

Capella_Ben
Posts: 88
Joined: Thu Aug 08, 2013 10:01 am
Location: Queensland, Australia

Post by Capella_Ben »

andrewsi wrote:Repetier or Marlin firmware? Just FYI, the drops provided on the Felix website are somewhat old and it's not terribly difficult to build the latest from Github. I can provide some assistance with that if needed, on the off chance that what you ran into is a bug that has been fixed in later versions.

The symptoms you describe (cold boot fixes it, etc.) are pretty likely a firmware problem rather than a defective board. If you reprint the same gcode does it lock up in the same place?
It's the Felix Marlin firmware. I have upgraded it once, so I know the procedure.

I haven't printed the exact same gcode twice as I'm in an iterative design process, making small changes each time.

I'm pretty familiar with the firmware now as I have mucked around with it before. I'll get the latest version and see how that goes.

Many thanks.
Ben
..
Felix 3.0 (upgraded from 2.0)

Makron
Posts: 110
Joined: Wed Mar 20, 2013 1:29 pm

Post by Makron »

http://forum.felixprinters.com/viewtopic.php?f=7&t=164

Here you go.

P.s im discovered printing from sd :D it works good never knew ;)

Capella_Ben
Posts: 88
Joined: Thu Aug 08, 2013 10:01 am
Location: Queensland, Australia

Post by Capella_Ben »

Thanks. I now see what you mean.
Ben
..
Felix 3.0 (upgraded from 2.0)

t800
Posts: 24
Joined: Sat May 11, 2013 10:28 am

Post by t800 »

I had the same problem , printer locking up while printing needing a power of to get it going again.
Took me a while to find out to find out it was caused by electro magnetic interference form the fridge standing next to the printer. The EMI was enough to corrupt the signal going over the usb cable.
Everytime the fridge kicked in the printer froze mid print an i had to remove power to get in working again (loosing the print).
I switched the usb cable to a shorter one which also has a ferrite cylinder that further shields agains EMI. I haven't got a lock-up during printing since.

Hans Spaan
Posts: 4
Joined: Mon Jan 13, 2014 7:41 pm
Location: NL

Post by Hans Spaan »

I had the same problem and spent two full days at finding a solution. The sources of trouble were: switching on of electric motors, of tube light and of fridges. Had the place checked by an electronics expert. He advised to go for netfilters. Just minutes before placing an order for a few netfilters, in an all or nothing attempt, I replaced the USB cable supplied by Felix Printers for another of equal length. Guess what? ... No lockups anymore! Btw, the replacement cable has no ferrite bead.

Post Reply