My first 3D printer

This is for general discussions. Also FAQ can be found here.

Moderator: speedake95

Post Reply
Trnquill
Posts: 66
Joined: Fri Oct 05, 2012 10:01 am

Re: My first 3D printer

Post by Trnquill »

evanr wrote:TRNQUILL: I have a similar problem where I have to reset the ramps board to connect. In addition, temperatures were updating but steppers weren't functioning. Things just stopped printing mid print... steppers seemed paralyzed. Have you been able to figure out why?
Nope. I use LCD/SD expansion now and only use computer to re-upload the firmware every now and then. I had to reset the board every time when connecting to computer to make it work. But never had the time nor energy to figure out why. I just thought that's the way it is.

What it comes to re-uploading the firmware I told above... that's a strange one! It seems like every time I move any of the axis too fast while the printer is NOT powered the firmware and/or settings get messed up in some way. I first noticed this few days after installing the LCD expansion. If I moved X or Y axis quite rapidly from one end to other the backlight of the LCD lit up! Next time I powered up the printer it has lost it's LCD configuration and displayed just random characters. After that I have witnessed the same thing happening at least five times. The latest occurance had me puzzled for some time and ruined quite a few prints: all else worked like a charm but Z-axis steps value was somewhat off. All the prints came out too high. I finally solved it by re-uploading the stock firmware (with the needed modifications to enable LCD) and after that did "restore defaults" (or something) followed by "save to memory" on the LCD. Only that brought the printer back to working order.

Any idea why moving axis by hand corrupts the controller? I know stepper motors work as generators when turned by hand but that should not harm the electronics, right?

Post Reply