Error: Format Error

Discussions about firmware/slicing software, tweaks and settings
Post Reply
hanscl
Posts: 5
Joined: Fri Mar 21, 2014 7:27 am

Error: Format Error

Post by hanscl »

Hello,

I just got my Felix V3.0 assembled a few days ago. I have successfully printed a few items, including the _40x10.STL sample.

Besides the usual fine tuning of temperature, filament tension and calibration everything worked fine.

Today I was trying to see how the gcode file would change by selecting different SFACT profiles and ever since I cannot print anything anymore. I always get the following error messages:

23:41:17.037 : Error:Format error
23:41:17.037 : Resend:97
23:41:17.058 : Error:Format error
23:41:17.058 : Resend:97
23:41:17.579 : Error:expected line 97 got 98

The line number varies depending on the STL file that I slice, but it just keeps repeating those last 3 lines. I have reset the printer, restarted my computer and (I believe) all settings are back to where they used to be when I was able to print.

I have searched the forum and the web for this error but I couldn't find anything. Has anybody had this error before? Any help would be appreciated.

I am attaching the penultimate gcode file (for _40x10.STL) that fails to print. Also, not sure if this has any relevance: I always get the error message "generated g-code not found", although slicing finishes successfully according to the log file:

23:39:12.615 : <SFACT> The penultimate file is saved as composition_penultimate.gcode
23:39:12.615 : <SFACT> The exported file is saved as composition_export.gcode
23:39:12.615 : <SFACT> It took 24 seconds to export the file.

The files are where they should be according to the error message, so I just open the penultimate gcode file from there and try to print, which then results in the error message shown above!

Thanks!
Attachments
composition_penultimate.gcode
(416.5 KiB) Downloaded 33 times

Dreide
Posts: 176
Joined: Sun Sep 29, 2013 12:32 am
Location: Lausanne, Switzerland

Post by Dreide »

Just open the composition_export.gcode file and then print. The 'penultimate' file is just good for debugging. Check your SFACT/Repetier directory settings though, because the correct gcode file should be found and loaded automatically after slicing.
Felix 2.0->3.0dual * Repetier (host+firmware) * KISSlicer Pro, Simplify3D * Cubify Design

hanscl
Posts: 5
Joined: Fri Mar 21, 2014 7:27 am

Post by hanscl »

Using the export file worked --- rookie mistake :) ! Thanks so much for your help.

Post Reply